re = /<img src=".*?\/([A-Z0-9]+)\.\w+"\s*\/><img src=".*?\/([A-Z0-9]+)\.\w+"\s*\/>/m
str = '<img src="http://www.example.com/app_res/emoji/1F60A.png" /><img src="http://www.example.com/app_res/emoji/1F389.png" />
<img src="http://www.example.com/app_res/emoji/1F61E.png" /><img src="http://www.example.com/app_res/emoji/1F339.png" />'
subst = '&#x$1; &#x$2;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result