use strict;
my $str = '<img src="http://www.example.com/app_res/emoji/1F60A.png" /><img src="http://www.example.com/app_res/emoji/1F389.png" />
<img src="http://www.example.com/app_res/emoji/1F61E.png" /><img src="http://www.example.com/app_res/emoji/1F339.png" />';
my $regex = qr/<img src=".*?\/([A-Z0-9]+)\.\w+"\s*\/><img src=".*?\/([A-Z0-9]+)\.\w+"\s*\/>/mp;
my $subst = '&#x$1; &#x$2;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";