#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\D*(\d+\s+\w+).*"
Local $sString = "Psychologist - 7 years on the website, online"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)