$re = '/\D*(\d+\s+\w+).*/';
$str = 'Psychologist - 7 years on the website, online';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;