using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D*(\d+\s+\w+).*";
string substitution = @"\1";
string input = @"Psychologist - 7 years on the website, online";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}