const regex = /\D*(\d+\s+\w+).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D*(\\d+\\s+\\w+).*', 'g')
const str = `Psychologist - 7 years on the website, online`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);