import Foundation
let pattern = #"\D*(\d+\s+\w+).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Psychologist - 7 years on the website, online"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)