re = /\D*(\d+\s+\w+).*/
str = 'Psychologist - 7 years on the website, online'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result