# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*[^a-zA-Z0-9]+\s*/ /gm;t' <<< "Estó es uná cádená con tildés
y esto son tildes sueltas: una ` tilde
y otra ´. Y ahora vienen más datos."