import Foundation
let pattern = #"\s*[^a-zA-Z0-9]+\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Estó es uná cádená con tildés
y esto son tildes sueltas: una ` tilde
y otra ´. Y ahora vienen más datos.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)