$re = '/\s*[^a-zA-Z0-9]+\s*/m';
$str = 'Estó es uná cádená con tildés
y esto son tildes sueltas: una ` tilde
y otra ´. Y ahora vienen más datos.';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;