re = /\s*[^a-zA-Z0-9]+\s*/m
str = 'Estó es uná cádená con tildés
y esto son tildes sueltas: una ` tilde
y otra ´. Y ahora vienen más datos.'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result