import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*[^a-zA-Z0-9]+\\s*";
final String string = "Estó es uná cádená con tildés\n"
+ "y esto son tildes sueltas: una ` tilde\n"
+ "y otra ´. Y ahora vienen más datos.";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}