package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*[^a-zA-Z0-9]+\s*`)
var str = `Estó es uná cádená con tildés
y esto son tildes sueltas: una \` tilde
y otra ´. Y ahora vienen más datos.`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}