using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*[^a-zA-Z0-9]+\s*";
string substitution = @" ";
string input = @"Estó es uná cádená con tildés
y esto son tildes sueltas: una ` tilde
y otra ´. Y ahora vienen más datos.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}