#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*[^a-zA-Z0-9]+\s*"
Local $sString = "Estó es uná cádená con tildés" & @CRLF & _
"y esto son tildes sueltas: una ` tilde" & @CRLF & _
"y otra ´. Y ahora vienen más datos."
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)