import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\s*#\\w+\\s*<\\/a>)(#(\\w+))";
final String string = "#hashtag <a target=\"_blank\" class=\"removable-mention\" data-mentionid=\"1\" href=\"/useroverview/1/Henkjan%20de%20Krijger\" contenteditable=\"false\">Henkjan de Krijger</a>#hashtag <a><br> #hashtag <a>#notahashtag</a>#hashtag\n\n"
+ "#hashtag ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}