re = /(?!\s*#\w+\s*<\/a>)(#(\w+))/
str = '#hashtag <a target="_blank" class="removable-mention" data-mentionid="1" href="/useroverview/1/Henkjan%20de%20Krijger" contenteditable="false">Henkjan de Krijger</a>#hashtag <a><br> #hashtag <a>#notahashtag</a>#hashtag
#hashtag '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end