import re
regex = re.compile(r"(?!\s*#\w+\s*<\/a>)(#(\w+))")
test_str = ("#hashtag <a target=\"_blank\" class=\"removable-mention\" data-mentionid=\"1\" href=\"/useroverview/1/Henkjan%20de%20Krijger\" contenteditable=\"false\">Henkjan de Krijger</a>#hashtag <a><br> #hashtag <a>#notahashtag</a>#hashtag\n\n"
"#hashtag ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")