# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+(?!\d*$)|[^\w\n]+(?!([A-Z]|$))//gm;t' <<< "Ndd12
12Ndd12
N dd 12
Nav G45up
ag$arwal"