use strict;
my $str = 'Ndd12
12Ndd12
N dd 12
Nav G45up
ag$arwal';
my $regex = qr/\d+(?!\d*$)|[^\w\n]+(?!([A-Z]|$))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";