$re = '/\d+(?!\d*$)|[^\w\n]+(?!([A-Z]|$))/m';
$str = 'Ndd12
12Ndd12
N dd 12
Nav G45up
ag$arwal';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;