const regex = /\d+(?!\d*$)|[^\w\n]+(?!([A-Z]|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(?!\\d*$)|[^\\w\\n]+(?!([A-Z]|$))', 'gm')
const str = `Ndd12
12Ndd12
N dd 12
Nav G45up
ag\$arwal`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);