#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d+(?!\d*$)|[^\w\n]+(?!([A-Z]|$))"
Local $sString = "Ndd12" & @CRLF & _
"12Ndd12" & @CRLF & _
"N dd 12" & @CRLF & _
"Nav G45up" & @CRLF & _
"ag$arwal"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)