import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?!\\d*$)|[^\\w\\n]+(?!([A-Z]|$))";
final String string = "Ndd12\n"
+ "12Ndd12\n"
+ "N dd 12\n"
+ "Nav G45up\n"
+ "ag$arwal";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}