re = /\d+(?!\d*$)|[^\w\n]+(?!([A-Z]|$))/m
str = 'Ndd12
12Ndd12
N dd 12
Nav G45up
ag$arwal'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result