using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?!\d*$)|[^\w\n]+(?!([A-Z]|$))";
string substitution = @"";
string input = @"Ndd12
12Ndd12
N dd 12
Nav G45up
ag$arwal";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}