# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\|(?>opening|insert|ending)\=)//gm;t' <<< "|mechanics={{mecha|p=GAT-04 Windam}}{{mecha|p=ZGMF-X23S Saviour Gundam}}{{mecha|p=Neutron Stampeder}}|opening={{track|p=Ignited}}
|insert={{track|p=Mizu no Akashi}}
|ending={{track|p=Reason}}}}"