import re
regex = re.compile(r"(\|(?>opening|insert|ending)\=)", flags=re.MULTILINE)
test_str = ("|mechanics={{mecha|p=GAT-04 Windam}}{{mecha|p=ZGMF-X23S Saviour Gundam}}{{mecha|p=Neutron Stampeder}}|opening={{track|p=Ignited}}\n"
"|insert={{track|p=Mizu no Akashi}}\n"
"|ending={{track|p=Reason}}}}")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)