const regex = new RegExp('(\\|(?>opening|insert|ending)\\=)', 'gm')
const str = `|mechanics={{mecha|p=GAT-04 Windam}}{{mecha|p=ZGMF-X23S Saviour Gundam}}{{mecha|p=Neutron Stampeder}}|opening={{track|p=Ignited}}
|insert={{track|p=Mizu no Akashi}}
|ending={{track|p=Reason}}}}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);