re = /(\|(?>opening|insert|ending)\=)/m
str = '|mechanics={{mecha|p=GAT-04 Windam}}{{mecha|p=ZGMF-X23S Saviour Gundam}}{{mecha|p=Neutron Stampeder}}|opening={{track|p=Ignited}}
|insert={{track|p=Mizu no Akashi}}
|ending={{track|p=Reason}}}}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result