import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((.)(?:(?1)|.?)\\2|(.)\\3*)$";
final String string = "a\n"
+ "aa\n"
+ "aba\n"
+ "abba\n"
+ "aaaa\n"
+ "aaaaa\n"
+ "abccba\n"
+ "12344321\n"
+ "0000010000\n"
+ "1234567890123456\n"
+ "1234321\n"
+ "bbbbbbbbbbbbbbb\n"
+ "aaaaaaaaaaa\n"
+ "abcdefghihgfedc\n"
+ "abcba\n"
+ "123431\n"
+ "ab\n"
+ "1232\n"
+ "上海自来水来自海上\n"
+ "ABCBAABCBA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}