import re
regex = re.compile(r"^((.)(?:(?1)|.?)\2|(.)\3*)$", flags=re.MULTILINE)
test_str = ("a\n"
"aa\n"
"aba\n"
"abba\n"
"aaaa\n"
"aaaaa\n"
"abccba\n"
"12344321\n"
"0000010000\n"
"1234567890123456\n"
"1234321\n"
"bbbbbbbbbbbbbbb\n"
"aaaaaaaaaaa\n"
"abcdefghihgfedc\n"
"abcba\n"
"123431\n"
"ab\n"
"1232\n"
"上海自来水来自海上\n"
"ABCBAABCBA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")