const regex = /^((.)(?:(?1)|.?)\2|(.)\3*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((.)(?:(?1)|.?)\\2|(.)\\3*)$', 'mg')
const str = `a
aa
aba
abba
aaaa
aaaaa
abccba
12344321
0000010000
1234567890123456
1234321
bbbbbbbbbbbbbbb
aaaaaaaaaaa
abcdefghihgfedc
abcba
123431
ab
1232
上海自来水来自海上
ABCBAABCBA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}