$re = '/^((.)(?:(?1)|.?)\2|(.)\3*)$/m';
$str = 'a
aa
aba
abba
aaaa
aaaaa
abccba
12344321
0000010000
1234567890123456
1234321
bbbbbbbbbbbbbbb
aaaaaaaaaaa
abcdefghihgfedc
abcba
123431
ab
1232
上海自来水来自海上
ABCBAABCBA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);