import Foundation
let pattern = #"^((.)(?:(?1)|.?)\2|(.)\3*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a
aa
aba
abba
aaaa
aaaaa
abccba
12344321
0000010000
1234567890123456
1234321
bbbbbbbbbbbbbbb
aaaaaaaaaaa
abcdefghihgfedc
abcba
123431
ab
1232
上海自来水来自海上
ABCBAABCBA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)