#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Nov(ember)*\.*\s\d{1,2}(st|nd|rd|th)*\,*\s\d{4}"
Local $sString = "Agenda November 9, 2018- Schuck-Lawrence.docx" & @CRLF & _
"Attendance Sheet Nov. 9, 2018 - Schuck-Lawrence.docx" & @CRLF & _
"Notice of IEP - Nov. 18th 2021" & @CRLF & _
"" & @CRLF & _
"st" & @CRLF & _
"nd" & @CRLF & _
"rd" & @CRLF & _
"th" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")