use strict;
my $str = 'Agenda November 9, 2018- Schuck-Lawrence.docx
Attendance Sheet Nov. 9, 2018 - Schuck-Lawrence.docx
Notice of IEP - Nov. 18th 2021
st
nd
rd
th
';
my $regex = qr/Nov(ember)*\.*\s\d{1,2}(st|nd|rd|th)*\,*\s\d{4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}