// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Nov(ember)*\.*\s\d{1,2}(st|nd|rd|th)*\,*\s\d{4}").unwrap();
let string = "Agenda November 9, 2018- Schuck-Lawrence.docx
Attendance Sheet Nov. 9, 2018 - Schuck-Lawrence.docx
Notice of IEP - Nov. 18th 2021
st
nd
rd
th
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}