const regex = /Nov(ember)*\.*\s\d{1,2}(st|nd|rd|th)*\,*\s\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Nov(ember)*\\.*\\s\\d{1,2}(st|nd|rd|th)*\\,*\\s\\d{4}', 'gm')
const str = `Agenda November 9, 2018- Schuck-Lawrence.docx
Attendance Sheet Nov. 9, 2018 - Schuck-Lawrence.docx
Notice of IEP - Nov. 18th 2021
st
nd
rd
th
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}