re = /Nov(ember)*\.*\s\d{1,2}(st|nd|rd|th)*\,*\s\d{4}/m
str = 'Agenda November 9, 2018- Schuck-Lawrence.docx
Attendance Sheet Nov. 9, 2018 - Schuck-Lawrence.docx
Notice of IEP - Nov. 18th 2021
st
nd
rd
th
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end