using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Nov(ember)*\.*\s\d{1,2}(st|nd|rd|th)*\,*\s\d{4}";
string input = @"Agenda November 9, 2018- Schuck-Lawrence.docx
Attendance Sheet Nov. 9, 2018 - Schuck-Lawrence.docx
Notice of IEP - Nov. 18th 2021
st
nd
rd
th
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}