$re = '/Nov(ember)*\.*\s\d{1,2}(st|nd|rd|th)*\,*\s\d{4}/m';
$str = 'Agenda November 9, 2018- Schuck-Lawrence.docx
Attendance Sheet Nov. 9, 2018 - Schuck-Lawrence.docx
Notice of IEP - Nov. 18th 2021
st
nd
rd
th
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);