import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=\\s)) # delimitador inicial\n"
+ "[+-]?[0-9]+ # entero con o sin signo\n"
+ "(?=\\s) # delimitador de finalización";
final String string = "Hace coincidir números enteros aislados para el sistema de numeración decimal.\n"
+ "test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}