$re = '/(?:^|(?<=\s)) # delimitador inicial
[+-]?[0-9]+ # entero con o sin signo
(?=\s) # delimitador de finalización/x';
$str = 'Hace coincidir números enteros aislados para el sistema de numeración decimal.
test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);