import Foundation
let pattern = ##"""
(?:^|(?<=\s)) # delimitador inicial
[+-]?[0-9]+ # entero con o sin signo
(?=\s) # delimitador de finalización
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
Hace coincidir números enteros aislados para el sistema de numeración decimal.
test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)