const regex = new RegExp('(?:^|(?<=\\s)) # delimitador inicial
[+-]?[0-9]+ # entero con o sin signo
(?=\\s) # delimitador de finalización', 'g')
const str = `Hace coincidir números enteros aislados para el sistema de numeración decimal.
test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}