import re
regex = re.compile(r'''
(?:^|(?<=\s)) # delimitador inicial
[+-]?[0-9]+ # entero con o sin signo
(?=\s) # delimitador de finalización
''', flags=re.VERBOSE)
test_str = ("Hace coincidir números enteros aislados para el sistema de numeración decimal.\n"
"test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")