re = /(?:^|(?<=\s)) # delimitador inicial
[+-]?[0-9]+ # entero con o sin signo
(?=\s) # delimitador de finalización/x
str = 'Hace coincidir números enteros aislados para el sistema de numeración decimal.
test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end