# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(...)(\\/([nsbpif]))+ ([\d])/@"$1"/g;t' <<< "Aaa/n 0
Bbb/b/p 0
Ccc/b/n/p 3"